The issue with PDF uploads has been resolved. Systems are operating normally. Thank you for your patience and understanding.
Posted Jul 07, 2025 - 13:55 UTC
Update
We are continuing to investigate this issue.
Posted Jul 07, 2025 - 13:36 UTC
Investigating
We are currently investigating reports of issues with PDF Uploads. Our team is working to identify the root cause and will provide updates as soon as more information becomes available.
Posted Jul 07, 2025 - 13:35 UTC
This incident affected: Global (app.h2xengineering.com), AU (au.h2xengineering.com), and UK (uk.h2xengineering.com).